Digital Workshop

Welcome to the Digital Workshop Message Boards
It is currently December 11th, 2018, 4:06 am

All times are UTC [ DST ]




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Variables display [ILMObject] when previewed
PostPosted: January 18th, 2005, 12:32 pm 
Offline

Joined: October 25th, 2004, 12:27 pm
Posts: 526
Location: Digital Workshop
Q: I have created a variable and inserted it into a text object to display its value. However, when I preview the publication, the text object always displays [ILMObject] instead of the correct value. How do I correct this?

A: This will occur if you have given a variable the same name as an object on the page. In other words, if you have created an text input box named 'input', you should not use any variables named 'input' on the same page or the variable will be set to [ILMObject].

The simplest solution is to rename either the object or the variable, so that their names no longer match. For example, you could rename the text input box to 'input field' or rename the variable to 'inputvar'.

When dealing with large publications consisting of hundreds of objects and variables, some authors find it useful to adopt a naming scheme, such as adding the prefix 'var' to all new variables. Not only does this make it easier to locate any variables they have created (as they will all be alphabetically grouped together under 'v'), but should ensure that variable names never conflict with object names.


Top
 Profile Visit website  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group